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Working Model Tutorial 
by Mark Minor 

 
This tutorial provides basic information for modeling planar rigid body dynamics using the Working Model 2D 
software that was included with your text: 

Robert L. Norton,  Design of Machinery:  An introduction to the Synthesis and Analysis of Mechanisms 
and Machines.  Second Edition.  New York, NY:  McGraw-Hill, 1999. 

The Working Model 2D software is capable of modeling the motion of rigid bodies that may be connected by a 
variety of joints and constraints, and acted on by actuators (motors, cylinders), connectors (springs & dampers), and 
environmental effects (gravity, viscous friction, & magnetism).  In this tutorial, the basics of modeling with 
Working Model 2D will be taught. 

1. Installation 
The following instructions can be used to install the software on your own computer.  To begin, you must have 
access to a PC or MAC with a CD-ROM drive.  Installation on the Mechatronics computers is planned, but you will 
need to place your disk in the CDROM drive to run the software.  Write your name and phone number on your CD 
in case you misplace it. 

1.1 PC Instructions (MAC installation has not been successful) 
1. Place the "Design of Machinery" CDROM included with your textbook in the CD drive of your 

computer. 
2. Browse the contents of the Disk using Windows Explorer or from "My Computer". 
3. Change to the Wminstaller directory. 
4. Run the Setup.exe program in that directory (the .exe extension may not be visible, depending on the 

configuration of your system). 
5. Follow the installation instructions.  Use the Serial Number provided during the installation.  Recall 

that you will probably need to type the last digit of the serial number when prompted. 

2. Setting up a model 

2.1 Force Fields 
Working Model calculates forces resulting from the following customizable force fields, which can be changed 
from the World menu. 

v Gravity (acting vertically downward in the workspace by default) 
v Air resistance (off by default) 
v Electrostatics (off by default) 
v User specified fields. (off by default) 

2.2 Collisions 
Collisions between bodies are activated or deactivated by selecting the bodies and choosing Do Not Collide or 
Collide from the object menu (on by default) 

2.3 Units 
SI units are assumed.  Several unit systems can be selected and customized by going to the View menu and 
selecting Numbers and Units...     
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2.4 Mass and Inertial Properties 
Every rigid body created in Working Model has geometric and material characteristics that are used to calculate 
mass and inertial properties.    
 

v Geometric properties are changed by graphically dragging or stretching the object or via keyboard by 
selecting the object and then choosing the Geometry option from the Window menu. 

v Material properties are modified from the Properties form which is opened by double-clicking the 
object or from the Properties  option from the Window menu.   Material properties are pre-defined and 
customizable.  Properties include: mass, density, coefficient of friction, elasticity, charge, initial 
position and initial velocity 

3. Creating Rigid Body Models 
Following are basic tools for creating rigid body models of planar systems using Working Model 2D software.  See 
HELP (by pressing the F1 key) accompanying the Working Model software under the Contents tab and "Working 
with Bodies" subject heading for further information. 

3.1 Creating Rigid Bodies 
Rigid body elements are created using the commands shown on the Rigid Body toolbar, Figure 1.  These elements 
can be combined using the Rigid Joint, shown below, to create more complex geometry.  Here is how  to create a 
Rigid Body element: 

1. Select one of the buttons on the toolbar, Figure 1. 
2. Click in the workspace and drag diagonally. 

 
Figure 1.  Rigid body toolbar. 

3.2 Creating Joint Elements 
The following tools are used to define joint properties for rigid bodies.  To apply them to a body do the following: 

1. Select the joint element from the Joint Element toolbar, Figure 2. 
2. Apply the element to the rigid body by clicking the mouse at the desired location.   

 
Figure 2.  Joint element toolbar. 

3.3 Constraining Rigid Body Motion 
Two methods may be used to constrain the motion of rigid bodies.  Method 1 combines Joint elements to form an 
implied constraint between two bodies.  Method 2 joins overlapping bodies or joins bodies by explicitly placing a 
particular joint at a specified location (not requiring joint elements to be created first.) 

3.3.1 Method 1: 
Assuming joint elements have been created on each of the bodies to be joined:   

1. Select the joint elements to Join by holding the Shift key and clicking the joint elements, 
2. Click the  command from the toolbar and the rigid bodies will align and be joined.  The type of 

joint created is dependent on the types of Joint elements selected.  Two point elements will create a 
pinned joint whereas a point and a slot element will create a pin-slot joint. 
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3.3.2 Method 2: 
Explicitly creating a particular type of joint at a specified location between overlapping bodies or between a body 
and ground is accomplished using the commands shown on the toolbar below.  Here is how: 

1. Select the joint from the toolbar, Figure 3. 
2. Click the desired location of the joint.  If two bodies are overlapping and the joint is placed on them, 

the joint will be created between them.  If the joint is applied to a single body (no overlap at the joint 
location), the joint will couple that body to ground. 

 
Figure 3.  Joint toolbar. 

4. Editing Rigid Bodies 

4.1 Changing the dimensions of a Rigid Body 
The dimensions of a rigid body can edited graphically by selecting the object and dragging its placeholders (the 
little black squares at the four corners of the object), via keyboard by selecting the object and choosing Geometry  
from the Window menu, or by selecting the body and modifying the data shown in status bar at the bottom of the 
screen, Figure 4.  

 
Figure 4.  Changing body properties using the status bar. 

4.2 Position and Rotation of UNCONSTRAINED rigid bodies 
Position:  Select the  tool, click on the object, and drag it. 
Rotation:  Select the Rotation Tool  and drag the body to the desired orientation.  Notice that as you position the 
mouse over the object, a small symbol will appear that indicates the center of rotation. 

4.3 Position and Rotation of CONSTRAINED rigid bodies 
Permissible orientations of a constrained body is defined by its constraints.  Using the  tool and clicking on the 
body it is possible to drag it through its possible positions and rotations.    

5. Couplers and Drivers 
The following couplers and drivers, Figure 5, are similar in usage 
to the rigid bodies described above.  They are all connected to 
rigid bodies at nodes and have properties, such as compliance or 
force, which can be edited by double clicking on the object.  
Rotary objects must be place on a pivoting node. 
 

 
Figure 5.  Couplers and Drivers Toolbar. 
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6. Building a Four-Bar Linkage 

1. Select the Rectangle Body tool.  
2. Draw a rectangle in the workspace by clicking one 

corner, dragging the mouse to the opposite corner, 
and then clicking again: 

3. Duplicate the Rectangle by picking Duplicate 
from the Edit menu (or by pressing the CTRL and 
D keys simultaneously.) 

4. Move the second rectangle directly above the first 
rectangle.  (Click-and drag it) 

5. Draw another rectangle, overlapping the top and 
bottom rectangles, Figure 7. 

6. Duplicate the last link and move it to the opposite 
end of the structure, Figure 8.  

7. Create Pin Joints between the links, Figure 8,  by 
selecting the pin joint tool and clicking in middle 
of the regions where the rectangles overlap (a 
small x will appear when your mouse is in the 
middle). 

8. Anchor/Ground the bottom link, Figure 8. 

 

 
Figure 6.  Building a fourbar linkage. Steps 1-2 

     
Figure 7.  Building a fourbar linkage,  Steps 3-5.    Figure 8.  Building a fourbar linkage,  Steps 6-7. 



ME EN 3200 – MECHATRONICS I – FALL 2003 
 

 

DEPARTMENT OF MECHANICAL ENGINEERING, UNIVERSITY OF UTAH 
SALT LAKE CITY, UTAH  

Page 5 of 10 

9. You can now move the linkage into different 
positions by clicking links and dragging them to a 
new location, Figure 9. 

10. Now simulate the linkage by clicking the run 
button.  It is assumed gravity acts downwards, so 
the linkage falls downward and collides with the 
bottom link,  Figure 10.   

v Press the STOP button to end the 
simulation and RESET to return the 
linkage to its initial position. 

v To show the intermediate positions shown 
below, click one of the Tracking options 
(Every 2 Fames) under the World menu. 

11. To allow full motion of the linkage, collisions 
must be turned off.  Select the objects and then 
from the Object menu choose Do not collide. 

12. Simulate the linkage again.  Since the linkage is 
symmetric (s+l=p+q), it is a "Special-case 
Grashof" linkage (Class III).  You should see the 
double crank, Figure 11,  and double rocker, 
Figure 11,  motions intermittently, shown below 
left and right, correspondingly.  Press the stop 
button after the simulation has run long enough to 
exhibit both types of motion (less than 20-30 
seconds) and reset the initial condition by clicking 
the Reset button. 

 
Figure 9.  Building a fourbar linkage.  Step 9. 

 
Figure 10.  Building a fourbar linkage, Step 10. 

   
Figure 11.  Building a fourbar linkage, Step 12, simulation. Figure 12.  Building a fourbar linkage, Step 12, simulation. 
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13. Turn the linkage into a Grashof mechanism by stretching/shrinking the length of the right vertical link to the 
proportions shown in Figure 13.  This is done by selecting the link and then dragging one of its handles (one of 
the four square boxes that appear at the corners of the link when it is selected) to the new dimension. 

14. Drive the linkage by placing a motor  at the node connecting the (short) crank link and the grounded link, 
shown in Figure 13. 

15. Run the model simulation.  You should see the crank-rocker behavior shown, Figure 14. 
 

 
Figure 13.  Building a fourbar linkage, Steps 13-14,  modified to be Grashoff and motor driven. 

 

 
Figure 14.  Building a fourbar linkage, Step 15, simulation of Grashoff linkage. 
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7. Crank Slider Example 
1. Place a slot on the background, Figure 15, using the slot element  
2. Draw a small link and use a pin joint  to anchor it to the background, Figure 15. 
3. Draw a longer link, overlapping the end of the small link and use a Pin Joint to join the two links, Figure 16. 
4. Now draw a small horizontal link, Figure 17, and attach a Square Point Element  to its middle. 

 
Figure 15.  Crank Slider Example.  Steps 1-2. 

 

 

Figure 16. Crank slider example, Step 3. 

 
Figure 17.  Crank slider example, Step 4. 
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5. Select the Square Point Element and Slot Joint simultaneously (hold the shift key) and press .  This will 
connect the link and slot. 

6. Now add point elements to the end of link 2 and to link 3, Figure 18. 

Figure 18.  Crank slider example, Step 6. Figure 19.  Crank slider example, Steps 7-12. 

 
7. Select the point elements and join them.  The links will now be joined, Figure 19. 
8. Now add a motor to the short link at the pin joint connected to ground, Figure 19. 
9. Draw a square block above link 3,  Figure 19.  This will be the load that is lifted. 
10. Measure the motor torque by selecting the Motor, opening the Measure menu and selecting the Torque 

Transmitted option.  A small box will appear with measurement information.  It can be moved anywhere in the 
workspace.  Click the arrow in its upper left corner to change it to a graph, or vise-versa. 

11. Add a similar graph for the Y-Position of the block, Figure 19. 
12. Now run the simulation.  Notice that both graphs are sinusoidal, but 180° out of phase. 
13. Change the motor speed (by double clicking on it to open its properties window) to determine at what speed the 

Square Block begins to lose contact with link 3.  Notice the effect that the loss of position has on the graphs. 
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8. Jumping Mechanism Example 
1. Draw a rectangular body and anchor it to ground.  For convenience, make sure that the vertical position is such 

that y=0.  This will serve as the ground that your system will jump from.   
2. Draw another body  (any desired shape) for  the robot body and add a vertical slot element 
3. Draw the pogo leg next to the body and add a SQUARE pin element.  Be sure to change the angle of the square 

pin to 90 degrees (in order to match the vertical slot). 

 
Figure 20.  Jumping mechanism example, Steps 1-3. 



ME EN 3200 – MECHATRONICS I – FALL 2003 
 

 

DEPARTMENT OF MECHANICAL ENGINEERING, UNIVERSITY OF UTAH 
SALT LAKE CITY, UTAH  

Page 10 of 10 

4. Select the square pin (again be sure that the angle of 
the pin is 90 deg.) and the slot element and click the 
“Join” button, Figure 21. 

5. Select the leg and then go to the Object menu and 
select Send to Back, .   

6. Now add a spring.  Attach one end to the pogo leg 
and the other to the body.  

7. Modify the free-length of the spring by selecting 
opening the spring’s properties menu.  This will place 
the spring in a deflected initial position that will apply 
a force to the system.  F=kx. Figure 24.  The “Active 
when” setting can also be modified to allow the 
spring to only act on the system if some condition 
(such as t<.5) exists. 

8. Add any necessary charts.  In  this case, we will 
generate a pot of body height  body height.  Select 
the body and under the Measure menu, select 
Position, and then Y-Graph.  See Figure 25. 

9. Run the simulation! See Figure 25. 
 

Figure 21. Step 4. Figure 22.  Step 5. 

Figure 23.  Step 6. 

Figure 24.  Step 7, spring 
properties. 

Figure 25.  Simulation result. 


